Jump to content


Photo

Audi A4 Wiper Problems


  • Please log in to reply
5 replies to this topic

#1 Sharpy1979

Sharpy1979

    Newbie

  • Members
  • Pip
  • 2 posts
  • I drive:Audi A4 1.9TDI 130 Sport - 2004/54

Posted 13 July 2009 - 01:06 PM

Hi Guys. I'm new to this forum and am trying to diagnose a problem with my wipers.

I have a 54plate A4 1.9tdi sport and my wipers have started struggling to work. They get halfway up and stop and then gradually moving an inch at a time over the space of 5minutes get through one full cycle. I've tried using WD40 to loosen the mechanism and around the base of the wiper arms and this worked temporarily.

My mind is telling me wiper motor but these parts can be quite costly. Could anything else be the problem before I go down this route?

Please help guys! and thanks in advance!!!

#2 docurley

docurley

    Newbie

  • Members
  • Pip
  • 2 posts
  • I drive:Audi A4 B6 1.8TQ S-Line (190bhp)

Posted 13 July 2009 - 02:31 PM

QUOTE (Sharpy1979 @ Jul 13 2009, 02:06 PM) index.php?act=findpost&pid=2750
Hi Guys. I'm new to this forum and am trying to diagnose a problem with my wipers.

I have a 54plate A4 1.9tdi sport and my wipers have started struggling to work. They get halfway up and stop and then gradually moving an inch at a time over the space of 5minutes get through one full cycle. I've tried using WD40 to loosen the mechanism and around the base of the wiper arms and this worked temporarily.

My mind is telling me wiper motor but these parts can be quite costly. Could anything else be the problem before I go down this route?

Please help guys! and thanks in advance!!!



Your wiper linkage is about to seize up on you.

QUOTE
tools needed

16mm socket
t30 torx
10mm socket
high quality grease
small hammer or heavy rachet to pound with
flat head screwdriver
needle nose plier or snap ring plier
carb/brake cleaner
about 1-2 hours
some cussing during removal

first remove top cover and should see this.
This image has been resized. Click this bar to view the full image. The original image is sized 800x600.

remove wiper arms by removing the 2 16mm nuts on the pivot, if you don't have a small puller, gently lift the pivot point up with a flat head and hammer the top threaded area down, that should separate the arm from the linkage.

remove 3 clips on the upper trim, left, right, and center.
This image has been resized. Click this bar to view the full image. The original image is sized 800x600.

push up to remove trim, the hood has to be at different angles to make removal/install possible or else the back corners would crush the trim.

after taking out the trim you should see the wiper trans in plain sight
This image has been resized. Click this bar to view the full image. The original image is sized 800x600.

remove 3 10mm bolts on the sides and center to loosen trans/motor assembly. also either cut the cloth holding the wires on the bottom side of the wiper motor. i prefer cutting because its easy and that area is not critical.

also remove the ECU cover as it is in the way of the linkages.

now loosen the gold center 13mm nut with a open end wrench on the wiper trans to ease removal since the pivot rods are free to move around. this might take a while as you cuss and swear trying to maneuver the assembly out, also don't scratch up too much of the paint under the hood.

don't yank on the assembly since there is a wire connector on the bottom.


#3 docurley

docurley

    Newbie

  • Members
  • Pip
  • 2 posts
  • I drive:Audi A4 B6 1.8TQ S-Line (190bhp)

Posted 13 July 2009 - 02:34 PM

QUOTE (docurley @ Jul 13 2009, 03:31 PM) index.php?act=findpost&pid=2751
Your wiper linkage is about to seize up on you.


QUOTE
now the wiper assembly is freed
This image has been resized. Click this bar to view the full image. The original image is sized 800x600.

the proper position of the gold gyro center section is to the left, that means the wiper is all the way in the down position. if the wipers are not in their correct resting position, this pivot arm with gold center nut is not in this position.

now the entire assembly is removed and able to be worked on. remove the top 13mm nut and the 3 gold t30 torx screws.
This image has been resized. Click this bar to view the full image. The original image is sized 800x600.

with the 3 screws and center nut gone, you can separate the wiper trans from the wiper motor.

now that the assembly is apart you can fix the wiper transmission assembly.

if you'll notice, the bottom of the shaft is starting to corrode. that is where our wiper trans start to fail and rust eventually seizes the assembly. if you managed to get this far there is a chance the wiper trans can be salvaged by sand paper and fresh grease.

if the "PLASTIC" joints on the linkage ends fail, you will need a new assembly. however if you catch this early enough, the plastic joints won't fail yet from pushing against a seized pivot housing.

This image has been resized. Click this bar to view the full image. The original image is sized 800x600.

there is a snap ring on top of the pivots where the wiper arms been the linkage.

you can remove the snap ring with a sharp needle nose plier or snap ring plier. it is a C type so you'll have to hit the edges off the C opening to slide off the clamp. there is a washer and 15x1mm o-ring under the snap ring
lightly tap the rotating pivot out of the housing. there are also metal washers on the bottom as well, they don't seal water out so the assembly rusts from the bottom up, you can try different methods to seal it up, but i left it alone.

clean up the shaft and housing with carb cleaner and paper towel, apply thin coat of grease on the shaft and use a screwdriver to coat the inside of the housing with grease.

installation is reverse of removal. only tighten the center gold nut after the assembly is in place, or else it's impossible to get it back in.



#4 Sharpy1979

Sharpy1979

    Newbie

  • Members
  • Pip
  • 2 posts
  • I drive:Audi A4 1.9TDI 130 Sport - 2004/54

Posted 13 July 2009 - 03:32 PM

Thanks Docurley the instructions and pics you supplied make it very clear.


#5 hulubadang

hulubadang

    Newbie

  • Members
  • Pip
  • 2 posts
  • I drive:audiA4 sport Cabriolet 3.0 54 reg

Posted 16 September 2009 - 12:17 PM

QUOTE (Sharpy1979 @ Jul 13 2009, 04:32 PM) index.php?act=findpost&pid=2753
Thanks Docurley the instructions and pics you supplied make it very clear.


Hi Guys.

I had similar problem with my audi A4 sport reg 54, sent to local garage thinking might be motor problem. Apparantly I was told taht the wiper seized up and there was no prob with the motor wiper. It cost me 60 dry.gif . They spend about 1 hr to fix it.


#6 cosminvs

cosminvs

    Newbie

  • Members
  • Pip
  • 1 posts
  • I drive:Audi A4 2004

Posted 02 October 2011 - 04:11 PM

Thank you very much Docurley. Very clearly described.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users